Passer au contenu principal
Procore

Comment l'exigence de Transport Layer Security v1.2 affecte-t-elle les utilisateurs?

Réponse

Pour la majorité des utilisateurs de Procore, l'exigence de Transport Layer Security (TLS) v1.2 n'aura aucun impact négatif sur les performances, la stabilité ou la sécurité. Certains utilisateurs doivent cependant connaître certains aspects du TLS v1.2. Ces considérations sont traitées dans les sections suivantes.

Contexte

L'architecture de sécurité réseau de Procore repose sur le protocole TLS (Transport Layer Security) pour garantir que l'interaction de l'utilisateur avec Procore sur Internet se déroule en toute sécurité sans que les transmissions soient vulnérables aux entités extérieures. TLS crypte un canal entre deux points d'extrémité (par exemple, entre un navigateur Web et un serveur Web) pour assurer la confidentialité et la fiabilité des données transmises via le canal de communication. Le principal avantage de TLS est la protection des données des applications Web contre la divulgation et la modification non autorisées lorsqu'elles sont transmises entre les clients (navigateurs Web) et le serveur d'applications Web, et entre le serveur d'applications Web et les programmes d'arrière-plan ou d'autres composants d'entreprise non basés sur un navigateur.

Par souci de protection de vos données et de conformité aux normes de l'industrie, à partir du milieu du deuxième trimestre 2019, Procore ne prendra en charge que les connexions réseau TLS v1.2. Les utilisateurs devront se connecter à Procore en utilisant le protocole TLS v1.2 pour éviter toute interruption de service.

Dates et étapes importantes

Voici quelques dates et étapes importantes liées à la mise à niveau de TLS v1.2 :

  • Février 2019 - Annonce initiale de l'exigence de TLS v1.2, prise en charge de TLS v1.0 / 1.1 obsolète.
  • 1er mai 2019 - Fin du support de TLS v1.0 / 1.1. Seules les connexions TLS v1.2 seront prises en charge après cette date.

Versions de navigateur prenant en charge TLS v1.2

Afin d'assurer un service ininterrompu, les utilisateurs de Procore doivent adopter l'une des versions de navigateur suivantes qui prennent en charge TLS v1.2.

  • Google Chrome - v30 ou version plus récente
  • Mozilla Firefox - v27 ou ultérieure
  • Microsoft Internet Explorer - v11 ou version ultérieure
  • Safari pour Mac OS X - v7 ou version ultérieure
  • Edge pour Windows 10

Prise en charge des appareils mobiles

Appareils Apple iOS
  • Tous les appareils Apple exécutant iOS v9.0.0 et les versions plus récentes sont compatibles avec TLS v1.2.
    • Tous les appareils iOS autres que l'iPhone (2007), l'iPhone 3G, l'iPhone 3GS, l'iPhone 4 et l'iPad d'origine (2010) d'origine peuvent être mis à niveau vers au moins iOS 9.
    • Les versions actuelles de Procore pour iOS nécessitent iOS 11 ou une version ultérieure.
Appareils Android
  • Les appareils Android utilisant la v4.4 et versions ultérieures du système d'exploitation Android sont compatibles avec TLS v1.2.
  • Les appareils Android exécutant v4.1 à v4.3 du système d'exploitation Android peuvent prendre en charge TLS v1.2 en fonction de la configuration du système, mais sont désactivés pour la prise en charge de TLS v1.2 par défaut.
  • Les appareils Android exécutant v4.0 et versions antérieures du système d'exploitation Android ne sont pas compatibles avec TLS v1.2.

Voir aussi