Pourquoi une erreur « L'opération d'importation a pris plus de temps que le délai d'expiration défini » est-elle apparue lors de l'exportation d'un ordre de changement d'engagement vers Sage 300 CRE?
Problème
Lors de la tentative d’exportation d’un ordre de changement à l'engagement (ODCE) de Procore vers Sage 300 CRE® avec l’outil Intégrations ERP, un message d’erreur s’affiche indiquant que l’opération d’importation prend plus de temps que le délai d’expiration défini. Que s’est-il passé et comment résoudre ce problème ?
- Message d'erreur :
L'opération d'importation a pris plus de temps que le délai d'expiration défini.
- Cause :
Certaines causes possibles de ce problème incluent :- Un processus supportant le serveur Sage 300 CRE® ne répond plus.
- Le client de synchronisation hh2 doit être redémarré.
Solution
Pour résoudre ce problème, procédez comme suit sur le serveur Sage 300 CRE® :
Étape 1 : Annulez la tâche du processus qui ne répond pas
Suivez ces étapes sur votre serveur Sage 300 CRE® :
- Lancez le gestionnaire de tâches.
Pointe! Pour savoir comment lancer le gestionnaire de tâches pour votre version de Microsoft Windows, visitez le support Microsoft. - Cliquez sur l'onglet Processus ou Détails.
- Mettez en surbrillance le visualiseur d’objets Timberline (c’est-à-dire tsOject.exe).
- Cliquez sur Terminer la tâche.
- Répétez les étapes ci-dessus pour chaque instance du visualiseur d'objets Timberline sur le serveur.
Étape 2 : Redémarrez le service de synchronisation hh2
Suivez ces étapes sur votre serveur Sage 300 CRE® :
- Démarrez le composant logiciel enfichable Services MMC.
Conseil! Pour savoir comment démarrer les services, visitez Services Microsoft Management Console (MMC). - Cliquez avec le bouton droit sur le service de synchronisation hh2 et choisissez Redémarrer.

Étape 3 : réessayer l'exportation ODCE
Après avoir terminé les étapes ci-dessus, réessayez le processus d’exportation. Pour obtenir des instructions, voir Exporter un ODCE vers Sage 300 CRE®.

